免费开源的私有云及云管平台来了,除虚拟化外,还支持纳管主流的 9 大公有云及私有云平台,欢迎大家安装体验!
能解决哪些问题?
- 将几台物理服务器虚拟化成一个私有云平台
- 需要一个紧凑而且功能相对完整的物理机全生命周期管理工具
- 将 VMware vSphere 虚拟化集群转换为一个可以自服务的私有云平台
- 在混合云的场景,能够在一个界面访问私有云和公有云
- 通过一个集中的入口访问分布在多个公有云平台上的多个账号
- 当前只使用一个云公有云账号但希望将来使用多云的用户
GitHub: https://github.com/yunionio/cloudpods
欢迎使用、体验+star
8 条回复 • 2023-01-28 10:18:31 +08:00
|
1
z779867650 2023 年 1 月 18 日
用 aws ec2 一键安装 无法访问 https://iso.yunion.cn 导致安装失败 还得修改 dns 才能成功安装
|
|
2
Cloudpods OP @z779867650 发下报错信息,我们排查下
|
|
3
z779867650 2023 年 1 月 18 日
TASK [common : init apt cache for debian] **************************************
fatal: []: FAILED! => {"changed": false, "dest": "/tmp/yunion.gpg-key.asc", "elapsed": 10, "msg": "Request failed: <urlopen error ('_ssl.c:711: The handshake operation timed out',)>", "url": "https://iso.yunion.cn/debian/10/3.9/x86_64/yunion.gpg-key.asc"} |
|
4
z779867650 2023 年 1 月 18 日
改完 dns 上面的倒是不报了 但是又出现的下面的错误
IMAGE_REPOSITORY=docker.io/yunion python3 run.py 127.0.0.1 IMAGE_REPOSITORY 这个貌似没有作用啊 TASK [primary-master-node/setup_k8s : Pull ocadm images on node] *************** fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": ["/opt/yunion/bin/ocadm", "config", "images", "pull", "--image-repository", "registry.cn-beijing.aliyuncs.com/yunion", "--onecloud-version", "v3.9.5", "--operator-version", "v3.9.5"], "delta": "0:00:40.746217", "end": "2023-01-18 07:05:45.225485", "msg": "non-zero return code", "rc": 1, "start": "2023-01-18 07:05:04.479268", "stderr": "failed to pull image \"registry.cn-beijing.aliyuncs.com/yunion/kube-proxy:v1.15.8\": output: Error response from daemon: Head https://registry.cn-beijing.aliyuncs.com/v2/yunion/kube-proxy/manifests/v1.15.8: net/http: TLS handshake timeout\n, error: exit status 1", "stderr_lines": ["failed to pull image \"registry.cn-beijing.aliyuncs.com/yunion/kube-proxy:v1.15.8\": output: Error response from daemon: Head https://registry.cn-beijing.aliyuncs.com/v2/yunion/kube-proxy/manifests/v1.15.8: net/http: TLS handshake timeout", ", error: exit status 1"], "stdout": "[config/images] Pulling registry.cn-beijing.aliyuncs.com/yunion/kube-apiserver:v1.15.8\n[config/images] Pulled registry.cn-beijing.aliyuncs.com/yunion/kube-apiserver:v1.15.8\n[config/images] Pulling registry.cn-beijing.aliyuncs.com/yunion/kube-controller-manager:v1.15.8\n[config/images] Pulled registry.cn-beijing.aliyuncs.com/yunion/kube-controller-manager:v1.15.8\n[config/images] Pulling registry.cn-beijing.aliyuncs.com/yunion/kube-scheduler:v1.15.8\n[config/images] Pulled registry.cn-beijing.aliyuncs.com/yunion/kube-scheduler:v1.15.8\n[config/images] Pulling registry.cn-beijing.aliyuncs.com/yunion/kube-proxy:v1.15.8", "stdout_lines": ["[config/images] Pulling registry.cn-beijing.aliyuncs.com/yunion/kube-apiserver:v1.15.8", "[config/images] Pulled registry.cn-beijing.aliyuncs.com/yunion/kube-apiserver:v1.15.8", "[config/images] Pulling registry.cn-beijing.aliyuncs.com/yunion/kube-controller-manager:v1.15.8", "[config/images] Pulled registry.cn-beijing.aliyuncs.com/yunion/kube-controller-manager:v1.15.8", "[config/images] Pulling registry.cn-beijing.aliyuncs.com/yunion/kube-scheduler:v1.15.8", "[config/images] Pulled registry.cn-beijing.aliyuncs.com/yunion/kube-scheduler:v1.15.8", "[config/images] Pulling registry.cn-beijing.aliyuncs.com/yunion/kube-proxy:v1.15.8"]} PLAY RECAP ********************************************************************* 127.0.0.1 : ok=63 changed=11 unreachable=0 failed=1 skipped=15 rescued=0 ignored=0 |
|
5
Cloudpods OP @z779867650 看着是用 127.0.0.1 的 IP ,修改为机器内网 IP 试试
|
|
6
Cloudpods OP 方便可以加入我们社区群,有问题可以群里实时反馈,谢谢。https://www.cloudpods.org/zh/docs/contact/
|
|
7
zkw111 2023 年 1 月 18 日
为什么选择用 Go 实现呢 是因为要纳管 k8s 的原因吗
|
如果想在 V2EX 获得更好的推广效果,欢迎了解 PRO 会员机制:
https://www.v2ex.com/pro/about
如果你经常使用铜币置顶主题,持有 V2EX Solana Token 会在每日签到时获得额外铜币:
https://www.v2ex.com/solana
https://www.v2ex.com/pro/about
如果你经常使用铜币置顶主题,持有 V2EX Solana Token 会在每日签到时获得额外铜币:
https://www.v2ex.com/solana